saab92x.com - Over 10% of all 9-2x owners registered

Saab92x.com is dedicated to the discussion of the Saab 9-2x sport wagon, based on the Subaru WRX.
Please register or login to post.

Welcome to Saab92x.com!
Saab92X.com is the premier Saab92X forum on the internet. Registered Users do not see the above ads.Please Register - It's Free!

#1 2020-06-20 11:51:05

2005saab92x
Member
Registered: 2019-01-28
User Number: 46311
Posts: 16

Super rough idle and little to no acceleration

Hi guys sorry if there’s another forum for this, I’ve been looking and couldn’t find one. I bought a 2005 Saab 92x linear with a manual transmission about two years ago with 105k miles from the original owner. The timing belt had been done and some other stuff they didn’t have paperwork for  unamused The day after buying it I had to replace the coil pack because of a misfire. After that it was smooth sailing until the exhaust broke right after the cat... got a cat back exhaust and she was all good once again. about 8 months ago the CEL came on for my gas cap which came back after I got a new one and cleared the code  banghead so I just dealt with the CEL and didn’t care (I had a VW before this, I was ready) then it started misfiring about a month ago, now at 126k and the plugs had never been done so I knew it was gonna happen, I replaced the spark plugs which was just annoying as hell and she was running fine, when I got it to work and could scan the codes, it had the old misfires and a couple evap leaks. I cleared it and about four days later it came back on with P1443 and P0420, I didn’t plug it In again after that because the car seemed fine until about a week ago. It idles very rough and doesn’t want to go anywhere when I give it gas, i can’t get it to work to use the code reader but i ordered one that should be here Tuesday. I replaced the EGR valve because that’s What I thought the problem was  sadbanana I am in need of help

Offline

 

Remove Advertisements Advertisement

Saab92X.com

Offline

 

#2 2020-06-21 23:25:35

saabe1
Member
From: Kansas
Registered: 2005-07-06
User Number: 459
Posts: 375
Website

Re: Super rough idle and little to no acceleration

The only thing I can think to try is the Mass AirFlow (MAF) sensor. I would disconnect it and see how it runs. It will default to some assumed values. It won't run well but might run better if that is the problem.
Sounds like you probably already know what the MAF sensor is... but if not it is right by the air box after the air filter.


saabe1, 9-2X Aero, Cold Weather, Satin Grey.
Performance: OEM Short Shift
Cosmetic/Functionality: OEM Trunk Tray, FHI - Gauge Pack, Rear Diff Protect, Rear Cup Holder and Cargo Net.

Offline

 

#3 2020-06-22 14:43:44

2005saab92x
Member
Registered: 2019-01-28
User Number: 46311
Posts: 16

Re: Super rough idle and little to no acceleration

I cleaned the MAF probably about 6 months ago, she was real dirty but ran way better after being cleaned! I’ll double check on that, thank you!

Offline

 

#4 2020-07-01 09:43:27

2005saab92x
Member
Registered: 2019-01-28
User Number: 46311
Posts: 16

Re: Super rough idle and little to no acceleration

I just wanted to update this Incase anyone runs into this same problem. It was my valve cover gaskets leaking so bad it was flooding the spark plugs and causing it to misfire one cylinder at a time. The misfires would only show up on my code reader while the car was running so the first couple times I scanned it, I was clueless. When I did my spark plugs a couple weeks ago I did notice the oil and make a note that I needed to do the valve cover gaskets but since the car didn’t show any misfires I was confused cause as I told my coworker “it feels like it’s misfiring, but it’s not?  It was, the codes were just pending cause I’d never let it run long enough for it to confirm the code. So after new plugs, wires and gaskets shes happy once again (for now).

Offline

 

#5 2020-07-01 11:36:35

thejameshimself
Member
From: Texas
Registered: 2013-12-26
User Number: 13280
Posts: 101

Re: Super rough idle and little to no acceleration

Did you replace the seals around the spark plugs in the valve cover as well?


US Production # 1936

Offline

 

#6 2020-07-04 10:52:54

2005saab92x
Member
Registered: 2019-01-28
User Number: 46311
Posts: 16

Re: Super rough idle and little to no acceleration

Of course, it would’ve completely defeated the purpose if I didn’t

Offline

 

Board footer

Site problems, bugs, or questions? Contact Administrator
All content copyright Saab92x.com 2005-2010
SAAB and the SAAB logos are trademarks of Saab Cars USA, Inc.